Servereisen voor Drupal 11 verder aangescherpt

Image
Drupal 11

De eisen voor een server om de toekomstige Drupal 11 te draaien zijn aangescherpt. Minimaal PHP versie 8.3 is nodig en voor de standaard MySQL-database is versie 8.0 noodzakelijk (of MariaDB 10.6, PostgreSQL 16 of SQLite 3.45). Al eerder gaven core-ontwikkelaars aan dat men overweegt om Windows niet langer te ondersteunen als server-platform.

De nog te verschijnen versie 11 van Drupal vertrouwt verder op Composer 2.7.0 om software te installeren en onderhouden. Verder gebruikt het frameworks als Symfony 7, PHPUnit 10 en jQuery 4.

De huidige versie Drupal 10 wordt ondersteund met software updates tot tenminste halverwege 2026.

Categorie├źn